ページの本文へ

Hitachi

ソフトウェア製品セキュリティ情報

2016.02.19 更新

COBOL2002 XML連携機能にXXEの脆弱性が存在します。

脆弱性ID

HS14-014

脆弱性の内容

COBOL2002 XML連携機能において,信頼できないXXEを用いたXMLドキュメントを通じて情報が漏えいしたり,DoS攻撃が引き起こされるおそれがあります。

影響を受けるバージョンを下記に示しますので,対策版の適用をお願いいたします。

対象製品

(凡例)
対象製品名 : 脆弱性が含まれる製品名

対象バージョン :

プラットフォーム
脆弱性が含まれるバージョン

対象製品名 : COBOL2002 Net Developer
対象製品名 : COBOL2002 Net Client Suite

対象バージョン :

Windows
03-00 - 03-00-/A, 03-01 - 03-01-/A,
02-00 - 02-00-/D, 02-01 - 02-01-/G(*1),
01-00, 01-01 - 01-01-/D, 01-02 - 01-02-/F, 01-03 - 01-03-/F(*1)

対象製品名 : COBOL2002 Net Client Runtime

対象バージョン :

Windows
03-00 - 03-00-/A, 03-01 - 03-01-/A,
02-00 - 02-00-/D, 02-01 - 02-01-/G(*1),
01-00, 01-01 - 01-01-/D, 01-02 - 01-02-/F, 01-03 - 01-03-/E(*1)

対象製品名 : COBOL2002 Net Server Suite

対象バージョン :

Windows
03-00 - 03-00-/A, 03-01 - 03-01-/A,
02-00 - 02-00-/D, 02-01 - 02-01-/G(*1),
01-00, 01-01 - 01-01-/D, 01-02 - 01-02-/F, 01-03 - 01-03-/F(*1)
HP-UX(IPF)
01-00 - 01-00-/G, 01-01 - 01-01-/J, 01-02 - 01-02-02
AIX
01-00 - 01-00-/C(*2), 01-01 - 01-01-/E(*2), 01-02(*2), 01-03 - 01-03-02(*2)

対象製品名 : COBOL2002 Net Server Runtime

対象バージョン :

Windows
03-00 - 03-00-/A, 03-01 - 03-01-/A,
02-00 - 02-00-/D, 02-01 - 02-01-/G(*1),
01-00, 01-01 - 01-01-/D, 01-02 - 01-02-/F, 01-03 - 01-03-/E(*1)
HP-UX(IPF)
01-00 - 01-00-/E, 01-01 - 01-01-/F, 01-02
AIX
01-00 - 01-00-/C(*2), 01-01 - 01-01-/E(*2), 01-02(*2), 01-03 - 01-03-02(*2)

対象製品名 : COBOL2002 Net Developer(64)

対象バージョン :

Windows
03-00 - 03-00-/A, 03-01 - 03-01-/A,
02-01(*1)

対象製品名 : COBOL2002 Net Server Suite(64)

対象バージョン :

Windows
03-00 - 03-00-/A, 03-01 - 03-01-/A,
02-01(*1)
HP-UX(IPF)
01-01 - 01-01-05, 01-02 - 01-02-02

対象製品名 : COBOL2002 Net Server Runtime(64)

対象バージョン :

Windows
03-00 - 03-00-/A, 03-01 - 03-01-/A,
02-01(*1)
HP-UX(IPF)
01-01 - 01-01-02, 01-02 - 01-02-02

対象製品名 : COBOL2002 Developer Professional/COBOL2002 Professional Option for Developer

対象バージョン :

Windows
03-01 - 03-01-/A
*1
対策版の提供予定はありません。なお,V3製品では対応しておりますので,対策バージョンをご確認ください。
*2
対策版の提供予定はありません。なお,V3製品では対応しております。

対策版の提供

(凡例)
対象製品名 : 脆弱性の対策済み製品名

対策バージョン :

プラットフォーム
脆弱性の対策バージョン 対策版提供日

対象製品名: COBOL2002 Net Developer
対象製品名: COBOL2002 Net Client Suite
対象製品名: COBOL2002 Developer Professional/COBOL2002 Professional Option for Developer

対策バージョン :

Windows
03-02 2014.08.05

対象製品名: COBOL2002 Net Client Runtime

対策バージョン :

Windows
03-02 2014.08.05

対象製品名: COBOL2002 Net Server Suite

対策バージョン :

Windows
03-02 2014.08.05
HP-UX(IPF)
01-02-03 2015.11.30
AIX
03-02 2015.09.10

対象製品名: COBOL2002 Net Server Runtime

対策バージョン :

Windows
03-02 2014.08.05
HP-UX(IPF)
01-02-03 2015.11.30
AIX
03-02 2015.09.10

対象製品名: COBOL2002 Net Developer(64)

対策バージョン :

Windows
03-02 2014.08.05

対象製品名: COBOL2002 Net Server Suite(64)

対策バージョン :

Windows
03-02 2014.08.05
HP-UX(IPF)
01-02-03 2016.02.01

対象製品名: COBOL2002 Net Server Runtime(64)

対策バージョン :

Windows
03-02 2014.08.05
HP-UX(IPF)
01-02-03 2016.02.01

セキュリティ対策版は改良版にて提供いたします。
「改良版の提供について」のWebページをご参照いただき,手順に従ってご入手ください。
(改良版の入手にはサポートサービスの契約が必要です)

更新履歴

2016.02.19
[対象製品]および[対策版の提供]を更新しました。
2014.06.10
このセキュリティ情報ページを新規作成および発信しました。
  • 弊社では,セキュリティ対応に関して正確な情報を提供するよう努力しておりますが,セキュリティ問題に関する情報は変化しており,当ホームページで記載している内容を予告なく変更することがありますので,あらかじめご了承ください。情報ご参照の際には,常に最新の情報をご確認いただくようお願いします。
  • 当ホームページに記載されている製品には,他社開発製品が含まれております。これらのセキュリティ情報については他社から提供,または公開された情報を基にしております。弊社では,情報の正確性および完全性について注意を払っておりますが,開発元の状況変化に伴い,当ホームページの記載内容に変更が生じることがあります。
  • 当ホームページはセキュリティ情報の提供を目的としたものであり,法律上の責任を負うものではありません。お客様が独自に行なった(あるいは行なわなかった)セキュリティ対応その他のご行為の結果につきまして,弊社では責任を負いかねます。
  • 当ホームページから他サイトのページへのリンクアドレスは情報発信時のものです。他サイトでの変更などを発見した場合には,リンク切れ等にならないように努力はいたしますが,永続的にリンク先を保証するものではありません。