Skip to main content

Hitachi

Software Vulnerability Information

Update: August 24, 2007

A DoS (Denial of Service) vulnerability was found in DABroker.

Vulnerability ID

HS07-026

Vulnerability description

If DABroker receives data unexpectedly through a port, a DoS might occur. If this happens, the stop command might not execute correctly, and connection requests from remote users might not be accepted.

This problem can occur if your system uses the remote connection function of DABroker. Affected products and versions are listed below. Please upgrade your version to the appropriate version, or apply the Workarounds.

Affected products

The information is organized under the following headings:

(Example)
Product name: Gives the name of the affected product.

Version:

Platform
Gives the affected version.

Product name: DABroker

Version(s):

Windows
02-01 to 03-14(*1)
Windows(IPF)
03-07 to 03-09-/E(*1)
HP-UX
02-00 to 03-02-/C, 03-04 to 03-13
HP-UX(IPF)
03-07 to 03-13(*1)
AIX
02-06 to 03-13(*1)
Solaris
02-02 to 03-11-/B(*1)

Product name: Cosminexus DABroker

Version(s):

Windows
03-00 to 03-06-/K(*1)
HP-UX
02-04 to 02-04-/B, 03-00 to 03-05-/D
AIX
03-00 to 03-06-/J(*1)
Solaris
03-05(*1)
*1
For details about these versions, contact your Hitachi support service representative.

Fixed products

The information is organized under the following headings:

(Example)
Product name: Gives the name of the fixed product.

Version:

Platform
Gives the fixed version, and release date.

Scheduled version:

Platform
Gives the fixed version scheduled to be released.

Product name: DABroker

Version(s):

HP-UX
03-02-/D July 9, 2007

Scheduled version(s):

HP-UX
03-04 to 03-13

Product name: Cosminexus DABroker

Version(s):

HP-UX
02-04-/C July 9, 2007
03-05-/E July 9, 2007

For details on the fixed products, contact your Hitachi support service representative.

Workarounds

Please carry out the following workaround until the fixed modules are available:

  • Set filtering rules on the OS or router so that only reliable IP addresses can access the TCP ports used by DABroker.

Revision history

August 24, 2007
This page is released.
  • Hitachi, Ltd. (hereinafter referred to as "Hitachi") tries to provide accurate information about security countermeasures. However, since information about security problems constantly changes, the contents of these Web pages are subject to change without prior notice. When referencing information, please confirm that you are referencing the latest information.
  • The Web pages include information about products that are developed by non-Hitachi software developers. Vulnerability information about those products is based on the information provided or disclosed by those developers. Although Hitachi is careful about the accuracy and completeness of this information, the contents of the Web pages may change depending on the changes made by the developers.
  • The Web pages are intended to provide vulnerability information only, and Hitachi shall not have any legal responsibility for the information contained in them. Hitachi shall not be liable for any consequences arising out of or in connection with the security countermeasures or other actions that you will take or have taken (or not taken) by yourself.
  • The links to other web sites are valid at the time of the release of the page. Although Hitachi makes an effort to maintain the links, Hitachi cannot guarantee their permanent availability.