ページの本文へ

Hitachi

ソフトウェア製品セキュリティ情報

2015.11.30 更新

Cosminexus HTTP Server, Hitachi Web ServerにCookieヘッダに関する脆弱性(CVE-2012-0053)が存在します。

脆弱性ID

HS12-033

脆弱性の内容

ステータスコード400(Bad Request)を返すときに,HTTPOnly属性のCookieヘッダがレスポンスボディに含まれる場合があります。

影響を受けるバージョンを下記に示しますので,対策版の適用または,下記[回避策]による回避をお願いいたします。

対象製品

(凡例)
対象製品名 : 脆弱性が含まれる製品名

対象バージョン :

プラットフォーム
脆弱性が含まれるバージョン

対象製品名 : Cosminexus HTTP Server

対象バージョン :

HP-UX(IPF)
09-00
AIX
09-00 - 09-00-01
Windows
09-00
Windows(x64)
09-00
Linux(x64)
09-00 - 09-00-02

対象製品名 : Hitachi Web Server

対象バージョン :

HP-UX
01-00 - 01-02-/D, 02-00 - 02-04-/I, 03-00 - 03-00-07
HP-UX(IPF)
02-02 - 02-04-/I, 03-00 - 03-00-07, 03-10 - 03-10-12, 04-00 - 04-00-06, 04-10 - 04-10-07, 04-20 - 04-20-01
AIX
01-01 - 01-02-/E, 02-00 - 02-04-/I, 03-00 - 03-00-07, 03-10 - 03-10-11, 04-00 - 04-00-06, 04-10 - 04-10-07
Windows
02-00 - 02-04-/K, 03-00 - 03-00-07, 03-10 - 03-10-11, 04-00 - 04-00-06, 04-10 - 04-10-06
Windows(x64)
04-10 - 04-10-07
Solaris
01-01 - 01-02-/D, 02-00 - 02-04-/F, 03-00 - 03-00-07, 03-10 - 03-10-11, 04-00 - 04-00-06
Solaris(x64)
04-00 - 04-00-06
Linux
01-01 - 01-01-/D, 02-00 - 02-06-/F, 03-00 - 03-00-07, 03-10 - 03-10-12, 04-00 - 04-00-06, 04-10 - 04-10-06, 04-20 - 04-20-01
Linux(IPF)
02-02 - 02-04-/F, 03-00 - 03-00-07, 03-10 - 03-10-11, 04-00 - 04-00-06, 04-10 - 04-10-06

対象製品名 : Hitachi Web Server - Security Enhancement

対象バージョン :

HP-UX(IPF)
02-04 - 02-04-/I

また本問題は,Cosminexus HTTP Server,Hitachi Web Serverを構成製品とする,Cosminexus製品にも該当します。Cosminexus製品に含まれるCosminexus HTTP Server,Hitachi Web Serverのバージョン,及びCosminexus製品の対策バージョンについては,サポートサービス窓口へご相談願います。

■Cosminexus V9

対象製品名 : uCosminexus Developer
対象製品名 : uCosminexus Application Server
対象製品名 : uCosminexus Service Platform
対象製品名 : uCosminexus Service Architect
対象製品名 : uCosminexus Application Server-R
対象製品名 : uCosminexus Primary Server Base

対象バージョン :

HP-UX(IPF)
09-00
Windows
09-00
Windows(x64)
09-00
Linux
09-00

対象製品名 : uCosminexus Application Server(64)
対象製品名 : uCosminexus Primary Server Base(64)
対象製品名 : uCosminexus Service Platform(64)

対象バージョン :

AIX
09-00

■Cosminexus V8

対象製品名 : uCosminexus Application Server Express
対象製品名 : uCosminexus Application Server Smart Edition
対象製品名 : uCosminexus Developer 01
対象製品名 : uCosminexus Application Server Standard
対象製品名 : uCosminexus Application Server Enterprise
対象製品名 : uCosminexus Service Platform
対象製品名 : uCosminexus Service Architect
対象製品名 : uCosminexus Developer Light
対象製品名 : uCosminexus Application Server Standard-R
対象製品名 : uCosminexus Developer Standard
対象製品名 : uCosminexus Developer Professional
対象製品名 : uCosminexus Primary Server Base
対象製品名 : uCosminexus Developer Professional for Plug-in

対象バージョン :

HP-UX(IPF)
08-00 - 08-70
AIX
08-00 - 08-70
Windows
08-00 - 08-70
Windows(x64)
08-50 - 08-70
Solaris
08-00 - 08-20
Solaris(x64)
08-20
Linux
08-00 - 08-70
Linux(IPF)
08-00 - 08-50

■Cosminexus V7

対象製品名 : uCosminexus Developer Light
対象製品名 : uCosminexus Application Server Standard
対象製品名 : uCosminexus Developer Standard
対象製品名 : uCosminexus Developer Professional
対象製品名 : uCosminexus Application Server Enterprise
対象製品名 : uCosminexus Application Server Smart Edition
対象製品名 : uCosminexus Primary Server Base
対象製品名 : uCosminexus Service Platform
対象製品名 : uCosminexus Service Platform - Messaging
対象製品名 : uCosminexus Service Architect

対象バージョン :

HP-UX
07-10
HP-UX(IPF)
07-00 - 07-60
AIX
07-00 - 07-60
Windows
07-00 - 07-60
Solaris
07-00 - 07-60
Linux
07-00 - 07-60
Linux(IPF)
07-10 - 07-60

■Cosminexus V6.7

対象製品名 : uCosminexus Developer Light
対象製品名 : uCosminexus Developer Standard
対象製品名 : uCosminexus Application Server Standard
対象製品名 : uCosminexus Developer Professional
対象製品名 : uCosminexus Application Server Enterprise

対象バージョン :

HP-UX
06-70 - 06-72
HP-UX(IPF)
06-70
AIX
06-70
Windows
06-70 - 06-71
Solaris
06-70
Linux
06-70 - 06-71
Linux(IPF)
06-70

■Cosminexus V6.0, V6.5

対象製品名 : Cosminexus Developer Light Version 6
対象製品名 : Cosminexus Developer Standard Version 6
対象製品名 : Cosminexus Primary Server Version 6
対象製品名 : Cosminexus Application Server Standard Version 6
対象製品名 : Cosminexus Developer Professional Version 6
対象製品名 : Cosminexus Application Server Enterprise Version 6
対象製品名 : Cosminexus Primary Server Base Version 6

対象バージョン :

HP-UX
06-00 - 06-50
HP-UX(IPF)
06-00 - 06-50
AIX
06-00 - 06-50
Windows
06-00 - 06-50
Solaris
06-00 - 06-50
Linux
06-00 - 06-50
Linux(IPF)
06-00 - 06-50

対象製品名 : uCosminexus Primary Server Base

対象バージョン :

HP-UX
06-51
HP-UX(IPF)
06-51
AIX
06-51
Windows
06-51
Solaris
06-51
Linux
06-51
Linux(IPF)
06-51

■Cosminexus V5.0, V5.5

対象製品名 : Cosminexus Application Server Version 5
対象製品名 : Cosminexus Developer Version 5

対象バージョン :

AIX
05-00 - 05-05
Windows
05-00 - 05-05
HP-UX
05-00 - 05-05
Solaris
05-05
Linux
05-05

対策版の提供

(凡例)
対象製品名 : 脆弱性の対策済み製品名

対策バージョン :

プラットフォーム
脆弱性の対策バージョン 対策版提供日

対象製品名 : Cosminexus HTTP Server

対策バージョン :

Linux(x64)
09-00-04 2012.11.14
HP-UX(IPF)
09-00-03 2012.10.17
AIX
09-00-03 2012.10.17
Windows
09-00-04 2012.12.19
Windows(x64)
09-00-04 2012.12.19

対象製品名 : Hitachi Web Server

対策バージョン :

Windows
04-10-08 2012.09.27
04-00-09 2015.06.19
03-10-14 2015.07.24
Windows(x64)
04-10-08 2012.09.27
Linux
04-20-02 2012.05.07
04-10-10 2015.01.06
04-00-09 2014.12.25
03-10-14 2015.01.16
Linux(IPF)
04-10-07 2012.06.01
04-00-09 2015.02.23
03-10-14 2015.03.02
HP-UX
03-00-08 2013.11.01
HP-UX(IPF)
04-20-03 2012.10.05
04-10-08 2012.10.25
04-00-08 2013.11.12
03-10-13 2013.09.19
AIX
04-10-08 2012.07.25
04-00-09 2015.01.29
03-10-14 2015.01.27
Solaris
04-00-07 2012.10.18
03-10-14 2015.04.24
サポートサービスをご契約されているお客様
サポートサービスの改良版の提供についてのホームページをご参照いただき,ホームページでご案内している手順にしたがって,対策版をご入手ください。
サポートサービスをご契約されていないお客様
当該製品に関しては,ライセンス管理を適切に行なう必要があるため,お手数ですが,お問い合わせフォームから提供をご依頼ください。ご依頼時には,お問い合わせ内容に「脆弱性ID」,「ご利用中の製品情報(製品名,バージョン,プラットフォーム,製番)」をご記入願います。

回避策

この脆弱性に対して下記の回避策があります。対策版を適用するまでの間,回避策を実施していただくようお願いいたします。

ErrorDocumentディレクティブで,エラーステータス番号400のメッセージをカスタマイズしてください。

なお、Hitachi Web Server V2以前の場合の定義例は以下になります。
    ErrorDocument 400 "Bad Request.

なお、Hitachi Web Server V3以降及びCosminex HTTP Serverの場合の定義例は以下になります。
    ErrorDocument 400 "Bad Request."

更新履歴

2015.11.30
[対策版の提供]を更新しました。
2015.06.30
[対策版の提供]を更新しました。
2015.05.15
[対策版の提供]を更新しました。
2015.04.15
[対策版の提供]を更新しました。
2013.12.05
[対策版の提供]を更新しました。
2013.09.30
[対策版の提供]を更新しました。
2013.01.18
[対象製品],[対策版の提供]および[回避策]を更新しました。
2012.12.25
このセキュリティ情報ページを新規作成および発信しました。
  • 弊社では,セキュリティ対応に関して正確な情報を提供するよう努力しておりますが,セキュリティ問題に関する情報は変化しており,当ホームページで記載している内容を予告なく変更することがありますので,あらかじめご了承ください。情報ご参照の際には,常に最新の情報をご確認いただくようお願いします。
  • 当ホームページに記載されている製品には,他社開発製品が含まれております。これらのセキュリティ情報については他社から提供,または公開された情報を基にしております。弊社では,情報の正確性および完全性について注意を払っておりますが,開発元の状況変化に伴い,当ホームページの記載内容に変更が生じることがあります。
  • 当ホームページはセキュリティ情報の提供を目的としたものであり,法律上の責任を負うものではありません。お客様が独自に行なった(あるいは行なわなかった)セキュリティ対応その他のご行為の結果につきまして,弊社では責任を負いかねます。
  • 当ホームページから他サイトのページへのリンクアドレスは情報発信時のものです。他サイトでの変更などを発見した場合には,リンク切れ等にならないように努力はいたしますが,永続的にリンク先を保証するものではありません。