Skip to main content

Hitachi

Software Vulnerability Information

Update: April 15, 2015

A vulnerability to denial-of-service attacks (CVE-2014-0224) was found in Hitachi Web Server.

Vulnerability ID

HS15-012

Vulnerability description

When using SSL functionality, a server process of Hitachi Web Server might terminate abnormally.

Affected products and versions are listed below. Please upgrade your version to the appropriate version.

Affected products

The information is organized under the following headings:

(Example)
Product name: Gives the name of the affected product.

Version:

Platform
Gives the affected version.

Product name: Hitachi Web Server

Version(s):

AIX, HP-UX, HP-UX(IPF), Linux, Linux(IPF), Solaris, Windows
01-00 to 02-03

This vulnerability exists in Cosminexus product, which bundles Hitachi Web Server. For details about the bundled version of Hitachi Web Server, and the fixed version of Cosminexus product, contact your Hitachi support service representative.

- Cosminexus V6

Product name: Cosminexus Developer Light Version 6
Product name: Cosminexus Developer Standard Version 6
Product name: Cosminexus Primary Server Version 6
Product name: Cosminexus Application Server Standard Version 6
Product name: Cosminexus Developer Professional Version 6
Product name: Cosminexus Application Server Enterprise Version 6
Product name: Cosminexus Primary Server Base Version 6
Product name: uCosminexus Primary Server Base

Version(s):

AIX, HP-UX, HP-UX(IPF), Linux, Linux(IPF), Solaris, Windows
06-00 to 06-20

- Cosminexus V5

Product name: Cosminexus Application Server Version 5
Product name: Cosminexus Developer Version 5

Version(s):

AIX, HP-UX, Linux, Solaris, Windows
05-00 to 05-05

Fixed products

The information is organized under the following headings:

(Example)
Product name: Gives the name of the fixed product.

Version:

Platform
Gives the fixed version, and release date.

Scheduled version:

Platform
Gives the fixed version scheduled to be released.

Product name: Hitachi Web Server

Version(s):

AIX, HP-UX, HP-UX(IPF), Linux, Linux(IPF), Solaris, Windows
02-04 or later

For details on the fixed products, contact your Hitachi support service representative.

Revision history

April 15, 2015
This page is released.
  • Hitachi, Ltd. (hereinafter referred to as "Hitachi") tries to provide accurate information about security countermeasures. However, since information about security problems constantly changes, the contents of these Web pages are subject to change without prior notice. When referencing information, please confirm that you are referencing the latest information.
  • The Web pages include information about products that are developed by non-Hitachi software developers. Vulnerability information about those products is based on the information provided or disclosed by those developers. Although Hitachi is careful about the accuracy and completeness of this information, the contents of the Web pages may change depending on the changes made by the developers.
  • The Web pages are intended to provide vulnerability information only, and Hitachi shall not have any legal responsibility for the information contained in them. Hitachi shall not be liable for any consequences arising out of or in connection with the security countermeasures or other actions that you will take or have taken (or not taken) by yourself.
  • The links to other web sites are valid at the time of the release of the page. Although Hitachi makes an effort to maintain the links, Hitachi cannot guarantee their permanent availability.